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Introduction  

In this lesson the basic structure of the computer system, its parts, functions and types of software are 

studied. Computer hardware and software work together. In this chapter the structure of computer, input-

output devices, memory, software and computer languages have been described. 

What is a Computer? 

• A computer is a device that transforms data into meaningful information. 

• It can accept, store, process and retrieve data. 

• Main characteristics – high speed, accuracy, storage capacity, versatility. 

Computer Organization 

Five basic functions of a computer: 

• Input – entering data/instructions 

• Storage (Memory) – storing data 

• Processing – processing the data 

• Output – displaying the result 

• Control – control of all operations 

Units:  

• Input Unit – accepts data 

• Control Unit (CU) – controls all operations 

• Memory Unit – stores data 

• Arithmetic Logic Unit (ALU) – addition, subtraction, multiplication, division, 
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• Output Unit – presents the result 

• CPU (Central Processing Unit) = ALU + CU 

Peripheral Devices 

• Input devices 

• Output devices 

• Other peripheral devices 

Input Devices 

• Keyboard 

• Mouse 

• Light Pen 

• Optical Scanner 

• Touch Screen 

• Microphone 

• Track Ball 

Keyboard 

• The most common input device 

• QWERTY keyboard is more popular 

• Generally 104 keys 

Mouse  

• Hand-operated device  

• Point and Click action 

• Menu selection, icon transfer 
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Light Pen 

• Light sensitive device 

• For selecting objects on the screen  

Optical Scanner 

• Converts image into electronic form 

• OCR (Optical Character Recognition) – converting scanned image into text 

Touch Screen 

• Giving input by touching the screen  

• Alternative to keyboard 

Microphone  

• Sound input device 

• Two types – Desktop, Hand held 

Track Ball 

• Device like an inverted mouse 

• Useful in less space 

Output Devices  

• Monitor 

• Printer 

• Plotter 

• Speaker 

Monitor 

• Main output device 
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Types: 

o CRT (Cathode Ray Tube) 

o LCD (Liquid Crystal Display) 

• Resolution – 800×600, 1024×768 etc. 

Printer 

Types: 

• Laser Printer – high quality, fast 

• Inkjet Printer – printing through ink  

• Dot Matrix Printer – low quality, more noise 

• Line Printer – high speed, used in large computers 

Plotter 

• For making large pictures/designs 

• Types:  

o Flat Bed Plotter 

o Drum Plotter 

Speaker 

Sound output device 

Memory System in Computer 

Two types: 

o Primary Memory – RAM 

o Secondary Memory – CD-ROM, Pen Drive 

• Primary memory is fast 

• Data is lost when the computer is switched off 
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Software 

• A group of instructions  

• Gives instructions to hardware to perform work 

Classification: 

• System Software 

• Application Software 

System Software 

• For operating the computer 

• Example: Operating System (OS) 

• Popular  OS – Windows, Unix, Linux 

Utilities 

• Antivirus 

• File Compression 

• File Management 

Application Software 

For specific tasks 

Types: 

• Generalized Package 

o Word Processing 

o Spreadsheet 

o Presentation 

o Database 
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• Customized Package 

o Payroll 

o Inventory Control 

o Student Information System 

Computer Languages 

1- Low Level Languages 

• Machine Language – based on 0 and 1  

• Assembly Language – use of mnemonics 

2- High Level Language 

• Easy to understand 

• Not machine dependent 

Examples: 

• BASIC: A simple and beginner level high level programming language, which is easy to learn. 

• COBOL: A high level language developed for commercial and business applications. 

• FORTRAN: A programming language developed for scientific and mathematical calculations. 

• C : A structured programming language, which is used in making system and application software. 

• C++ : An object oriented programming language, which is an advanced form of C language. 

Compiler and Assembler 

• Compiler – converts high level language into machine language 

• Assembler – converts assembly language into machine language 

• Source Program → Object Program 
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Q-1. Write the five basic functions of a computer. 

Answer-  The five basic functions of a computer are – input, storage, processing, output and control. All 

these functions together make the computer fully capable of working. 

Q-2.  What is CPU? 

Answer- CPU stands for Central Processing Unit. It includes ALU and CU. It is the brain of the computer 

that performs all calculations and control functions. 

Q-3.  Write the difference between system software and application software. 

Answer- System software performs the task of running and controlling the computer, such as operating 

system. Application software is made for specific tasks, such as word processing or spreadsheet. 

Q-4.  Tell the difference between high level and low level language. 

Answer- Low level language is based on machine and is difficult to understand. High level language is 

simple, user friendly and not machine dependent. 

 Q-5. Write the types of printer. 

Answer- The main types of printer are – Laser Printer, Inkjet Printer, Dot Matrix Printer and Line Printer. 

Their speed, quality and usage are different. 
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Introduction  

In this chapter typing text in a document, editing, formatting, copying-cutting and doing page setting 

have been taught. With the help of Word 2007, text can be made attractive and well-organized. 

Working With Text 

Typing Text 

• The text is displayed where the cursor is located. 

• When the line is completed, the text automatically moves to the next line. 

• Press Enter to create a new paragraph. 

Inserting Text 

• Change the cursor position using Arrow Keys or Mouse. 

• Shortcuts: 

o Home – beginning of the line 

o End – end of the line 

o Ctrl+Home – beginning of the document 

o Ctrl+End – end of the document 

Spacebar and Tabs 

• Use Spacebar for distance between words. 

• Use Tab Key to create columns. 

• Do not use extra spaces. 
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Paragraph Markers (¶) 

• The ¶ symbol shows returns, spaces, tabs. 

• Show or hide using the Show/Hide button. 

Selecting (Highlighting) Text 

• Word – Double Click 

• Paragraph – Triple Click 

• Entire document – Ctrl + A 

Deleting Text 

• Backspace – deletes the text to the left. 

• Delete – deletes the text to the right. 

Replacing Text 

• Select the text → type new text. 

• The old text will be replaced automatically. 

Click and Type 

Text can be inserted by double clicking anywhere on the page. 

Formatting Text 

Main options: 

• Font Face – type of letters 

• Font Size – size of letters (in Points) 

• Bold, Italic, Underline – letter style  

• Alignment – Left, Center, Right, Justify  

• Indent Increase/Decrease 

• Highlight Color 
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• Font Color 

Format Painter 

• Applies the formatting of one text to another.  

Formatting Paragraphs 

• A new paragraph is created by pressing Enter. 

• Paragraph format applies to the entire paragraph. 

Line Markers 

• Shift + Enter – new line, but not a new paragraph. 

Center, Right and Left Alignment  

Text can be aligned Left, Center, Right or Justify. 

Indenting Text 

• Indent the paragraph using Indent Marker. 

• Hanging Indent – indent all lines except the first line. 

Tab Stops 

1. Default Tab – 0.5 inch 

Types: 

• Left Tab 

• Center Tab  

• Right Tab 

• Decimal Tab 

Line Spacing 

• Single 

• 1.5 Line 
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• Double 

Paragraph Spacing 

• Before and After spacing can be set. 

• When a paragraph is deleted, extra blank line does not remain. 

Borders and Shading 

• Border can be applied around the paragraph. 

• Shading can be applied in the background.  

Bulleted And Numbered Lists 

Creating a Bulleted and Numbered List 

• Choose Bullets or Numbering from Formatting Toolbar. 

• On pressing Enter, the next bullet is created automatically. 

 

Nested List 

A sub-list is created by Increase Indent. 

Formatting Bulleted and Numbered Lists  

• The bullet symbol can be changed. 

• The Number Style can be changed. 
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Copying Text And Moving (Cutting) Text 

Use of Clipboard 

• Copied or Cut text is stored in the Clipboard. 

• It can be reused by Paste. 

Moving Text 

Ctrl + X → Ctrl + V 

Copying Text  

Ctrl + C → Ctrl + V 

Spelling And Grammar 

• Red line under incorrect word. 

• Green line under grammar error.  

• Press F7 to check. 

• Ignore, Change, Add options available. 

Page Formatting 

Page Design from Page Layout Tab. 

Page Margins 

• Can be changed using Ruler. 

• Can be set using Page Setup Dialog Box. 

• Predefined Margin options available. 
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Q-1. What is text formatting? 

Answer-  Making the text attractive by changing its style, size, color and Alignment is called text 

formatting. It includes options such as Font, Size, Bold, Italic etc. 

Q-2.  What is the use of Format Painter? 

Answer- Format Painter is used to copy the formatting of one text and apply it to another text. By this, 

the same style can be applied quickly. 

Q-3. What is Clipboard? 

Answer- Clipboard is a temporary memory where Cut or Copied text is stored and can be pasted later. 

Q-4.  Tell the difference between Line Spacing and Paragraph Spacing. 

Answer- Line Spacing is the distance between two lines, whereas Paragraph Spacing controls the distance 

between two paragraphs. 

 Q-5. Write the process of checking Spelling and Grammar. 

Answer- Spelling and Grammar can be checked by pressing F7. For an incorrect word, select the correct 

word from the Suggestion Box and click on Change. 
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Introduction 

Presentation is used to present your ideas, information or topic effectively in front of people. Microsoft 

PowerPoint is a popular software with the help of which slide based presentation is prepared. 

Starting Powerpoint Program 

• PowerPoint is a software for creating presentation. 

• Text, pictures, sound, video and graphics can be added in it. 

PROCESS OF STARTING POWERPOINT 

• Click on Start button 

• Select All Programs 

• Click on Microsoft Office 

• Select Microsoft Office PowerPoint 2007 

Creating Presentation 

• When PowerPoint starts, Blank Presentation appears. 

• In this, presentation is prepared by creating new slides. 

• There are various Tabs and Commands in Ribbon. 

Installed Templates 

• Template is a pre-prepared design. 

• It makes creating presentation easier. 

• Select the desired template and click on Create. 
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Design Template 

• Design Template determines the background and format of the slide. 

• This makes the appearance of the slide attractive. 

Blank Presentation 

• When no template is to be used then Blank Presentation 

is selected. 

• In this the user prepares the design of the slide himself. 

Slide Layout 

• Slide Layout determines the structure of the slide. 

• Many types of layouts are available in PowerPoint. 

Main Layouts 

• Title Slide 

• Title and Content 

• Section Header 

• Two Content 

• Comparison 

• Title Only 

•  Blank 

• Content with Caption 

• Picture with Caption 

Selecting The Content 

The following elements can be added in the slide: 

• Insert Table 

• Insert Chart 
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• Insert SmartArt Graphic 

• Insert Picture 

• Insert Clip Art 

• Insert Media Clip 

Open An Existing Presentation 

• Select Office Button → Open 

• Select the required file. 

• Click on Open 

Viewing Slides 

There are several views to view slides in PowerPoint. 

Main Views 

• Normal View 

• Slide Sorter View 

• Slide Show View 

Normal View 

• The screen is divided into three parts. 

• It contains Slide Pane, Outline Pane and Notes Pane. 

• Most of the work is done in this view. 

 Slide Sorter View  

• In this all slides appear in the form of small images. 

• It becomes easy to change the order of slides. 
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Slide Show View 

• In this slides appear on the full screen. 

• It is used to present the presentation. 

Design Tips 

• Use contrasting colors for text and background. 

• Use large font size for large room. 

• Use short and clear sentences. 

• Use simple Transition effects. 

• Do not keep too much text or graphics in the slide. 

Working With Slides 

• Slides are the main part of the presentation. 

• Text, picture, table etc. can be added in it. 

Applying Design Template 

Select the desired template from Design Tab. 

Changing Slide Layout 

• Select Home → Layout. 

• Select one from the available layouts. 

Adding Slide As A New Slide 

• New slide is added to add new information in the presentation. 

• There are many ways to add a new slide in PowerPoint. 

• Select Home → New Slide. 

• Slides can also be added from other files. 
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Slides From Outline 

• Slides can also be created from the outline of a text file. 

• The text written in the outline directly converts into Slide Title and Content. 

• For this Home → Slides → Slides from Outline is used. 

Duplicate Selected Slides 

• If the same type of slide is needed again then Duplicate Slide can be created. 

• This creates an exact copy of the current slide. 

Process 

• Select the slide. 

• On it Right Click → select Duplicate Slide. 

• Or press Ctrl + Shift + D. 

Reordering Slides 

In Slide Sorter View the slide can be moved by Drag to change the position. 

Hide Slide 

To hide a slide temporarily use the Hide Slide option. 

Moving From One Slide To Another 

• Scroll Bar 

• Next Slide Button 

• Previous Slide Button 

• Outline Pane 

Working With Text 

PowerPoint provides facility to add, edit and format text. 
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inserting text 

Ways to add text: 

• Outline Text  

• Text Box 

Text Box 

• Text Box is used to add text in the slide. 

• Its size and position can be changed. 

Formatting Text 

Font, Size, Style, Color of the text can be changed. 

Line Spacing 

Determines the distance between lines. 

Change Case 

• Sentence Case 

• Upper Case 

• Lower Case 

• Title Case 

• Toggle Case 

Bullet List 

Bullet List is used to display main points in an organized form. 

Number List 

Numbered List is used to display points in sequence. 

Text Box Properties 

• Text Box is used to write text in the slide. 
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• Its size, position and format can be changed. 

Main Properties 

• Changing Size – Size of the text box can be increased or decreased. 

• Moving – Text box can be moved to any place on the slide. 

• Size is changed by Resize Handles. 

• Format of text can be changed by Formatting. 

Deleting Text Box 

• To delete text box from the slide select it. 

• Press Delete Key. 

• The text box will be removed from the slide. 

Copying Text Box 

• Select the text box. 

• Press Ctrl + C. 

• Press Ctrl + V where it is to be placed. 

Moving Text Box 

• Select the text box. 

• Drag it to the desired place using the mouse. 

Adding Picture 

Adding picture in the slide makes the presentation attractive. 

Process 

• Click on Insert Tab 

• Select Picture option 

• Select picture file 
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• Click on Insert 

Adding Clip Art 

Clip Art is a collection of already available pictures. 

Process 

• Select Insert → Clip Art 

• Select the desired picture 

• Add in the slide 

Slide Transition 

The effect of moving from one slide to another slide is called Transition. 

USE: Makes the slide show more attractive. 

Animation Effect 

Adding Movement Effect to text or pictures of the slide is called animation. 

Examples: Appear, Fade, Fly In 

Running Slide Show: To present the prepared presentation Slide Show is run. 

Process 

• Select Slide Show Tab 

• Click on From Beginning. 
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Q-1. What is Presentation? 

Answer-  Presentation is the process of presenting information, ideas or topic in front of the audience 

through slides. Generally PowerPoint software is used to create it. 

Q-2.  Write the types of Slide Views in PowerPoint. 

Answer- There are mainly three types of slide views in PowerPoint: 

• Normal View – For creating and editing slides. 

• Slide Sorter View – For viewing and changing the order of all slides. 

• Slide Show View – For showing the presentation on full screen. 

Q-3.  What is Slide Layout? 

Answer- Slide Layout determines the structure of the slide. It decides where the title, text, picture or other 

content will appear in the slide. Various types of layouts are available in PowerPoint which can be selected 

according to requirement. 

Q-4.  What is Text Box? Write its uses. 

Answer- Text Box is a tool to write and display text in the slide. With its help text can be placed at any 

place on the slide. The size, position and format of the text box can be changed according to requirement. 

 Q-5. Write the difference between Slide Transition and Animation. 

Answer- Slide Transition is the visual effect of moving from one slide to another slide. 

Animation is the movement effect applied to text or pictures within the slide which makes the 

presentation more attractive. 
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